Skip to main content
All CollectionsDiscover YocoExplore card machines
Which phones/tablets are compatible with Yoco?
Which phones/tablets are compatible with Yoco?
Updated over a week ago

Smartphones and tablets are ever-evolving, and new brands are surfacing on a regular basis. So, we’ve compiled a list of the device specifications that will work with downloading the Yoco Mobile App and connecting to your Yoco card machine - if you're using your Yoco paired with a smart device.

NOTE: These are basic guidelines and specifications may vary from device to device. You can check the specifications of your device at gsmarena.com.

iOS

  • Your phone or tablet must be running the latest iOS software version, or iOS 9.3.5 and above.

  • You must run an updated version of the Yoco App: Version 3.1.0 build 3 or higher, for iOS.

Most Apple iOS devices (running the latest iOS version) are compatible with Yoco.

The following Apple devices are compatible with the Yoco Point of Sale:

  • iPhone 5S (and above)

  • iPod Touch 7 (and above)

  • iPad 5 (and above)

If you have a device listed above and the app does not work, please ensure that you have the latest version of the Yoco Mobile App. The latest version of the Yoco Mobile App can be downloaded from your Apple App Store.

Android

  • Your phone or tablet must be running at least Android 5 or higher.

  • Your phone or tablet should have 2GB RAM or more, available.

  • 3G/LTE/Wireless internet connectivity, GPS and Bluetooth connectivity.

  • You must run an updated version of the Yoco Mobile App: Version 3.3.0 or higher, for Android.

We generally support the Android devices from the past 2 years on the latest version of the Yoco app (5 and higher).

For the best experience, we recommend a phone or tablet with the additional following specs:

  • Quad core CPU

IMPORTANT: If the app is not available for download in the Google Play Store, then it has not met the minimum requirements for the app.

If you're still unsure if your phone is compatible with Yoco, please download this Spec Device app. Navigate to 'My Spec Link' and email [email protected]. We'll then be able to confirm if your device is compatible.

Devices not supported

  • Blackberry

  • Windows Phone

  • Vodacom Smart 4 mini

  • Alcatel

  • Hisense

  • Vodafone Smart Tab

  • Acer

  • Karbonn

  • Smartpoynt

  • Mediatek chipset

  • Redmi

  • Sony Experia E4

  • ZTE Blade C310

  • Huawei Ascend Y220

  • Huawei P8 and Huawei P8 lite

Did this answer your question?